Current Version: 4.2.1

Version History

The demo version is fully functional, but all pictures are watermarked.

In order to uninstall the demo version, simply drag it to the trash.
Download Demo
Version 4.2.1
Logoist 4 is exclusively available on the Mac App Store.

macOS 10.14 Mojave, macOS 10.15 Catalina or macOS 11 Big Sur is required to use Logoist 4. Fully optimized for M1-based Macs.
Buy Logoist 4
US$ 39.99 on the Mac App Store

Frequently asked questions about Logoist 4

• I want to try Logoist 4 before buying, what do I do?
Show Answer
• How can I send feedback?
Show Answer
• I like Logoist 4, what are my purchasing options?
Show Answer
• Is Logoist 4 compatible to macOS 10.14 Mojave and macOS 10.15 Catalina?
Show Answer
• Am I allowed to run Logoist 4 on more than one Mac?
Show Answer

Newest Support Articles about Logoist 4

User Guide

Logoist 4.2.1
ende
Logoist 3.2
endefr
Logoist 2.6.1
endefr
Logoist 1.2.5
ende

Boolean operators in Logoist 4

Exporting your design from Logoist 4

Drawing with the path tool in Logoist 4

Cropping your design project in Logoist 4

How to draw a panda in Logoist 4

Applying filters in Logoist 4